package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(\S+(?:\s+\S+)*)\s*`)
var str = ` somet hing `
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}