import re
regex = re.compile(r"\s*(\S+(?:\s+\S+)*)\s*")
test_str = " somet hing "
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)