use strict;
my $str = ' somet hing ';
my $regex = qr/\s*(\S+(?:\s+\S+)*)\s*/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";