const regex = new RegExp('\\s*(\\S+(?:\\s+\\S+)*)\\s*', 'g')
const str = ` somet hing `;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);