#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[0-9]*\n[0-9: -,->]+\n(<[^<]+>){2}([^<]+)<\/font><\/b>"
Local $sString = "1" & @CRLF & _
"00:00:07,133 --> 00:00:10,833" & @CRLF & _
"<b><font color='#ffd109'>- It was ninety one years ago, today</font></b>" & @CRLF & _
"2" & @CRLF & _
"00:00:07,133 --> 00:00:10,833" & @CRLF & _
"<b><font color='#ffd109'>Line two</font></b>" & @CRLF & _
"244" & @CRLF & _
"00:00:07,133 --> 00:00:10,833" & @CRLF & _
"<b><font color='#ffd109'>Line three</font></b>"
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)