use strict;
my $str = '1
00:00:07,133 --> 00:00:10,833
<b><font color=\'#ffd109\'>- It was ninety one years ago, today</font></b>
2
00:00:07,133 --> 00:00:10,833
<b><font color=\'#ffd109\'>Line two</font></b>
244
00:00:07,133 --> 00:00:10,833
<b><font color=\'#ffd109\'>Line three</font></b>';
my $regex = qr/[0-9]*\n[0-9: -,->]+\n(<[^<]+>){2}([^<]+)<\/font><\/b>/mp;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";