// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]*\n[0-9: -,->]+\n(<[^<]+>){2}([^<]+)<\/font><\/b>").unwrap();
let string = "1
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>- It was ninety one years ago, today</font></b>
2
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>Line two</font></b>
244
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>Line three</font></b>";
let substitution = "\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}