package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]*\n[0-9: -,->]+\n(<[^<]+>){2}([^<]+)<\/font><\/b>`)
var str = `1
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>- It was ninety one years ago, today</font></b>
2
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>Line two</font></b>
244
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>Line three</font></b>`
var substitution = "\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}