# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[0-9]*\n[0-9: -,->]+\n(<[^<]+>){2}([^<]+)<\/font><\/b>"
test_str = ("1\n"
"00:00:07,133 --> 00:00:10,833\n"
"<b><font color='#ffd109'>- It was ninety one years ago, today</font></b>\n"
"2\n"
"00:00:07,133 --> 00:00:10,833\n"
"<b><font color='#ffd109'>Line two</font></b>\n"
"244\n"
"00:00:07,133 --> 00:00:10,833\n"
"<b><font color='#ffd109'>Line three</font></b>")
subst = "\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.