import Foundation
let pattern = #"[0-9]*\n[0-9: -,->]+\n(<[^<]+>){2}([^<]+)<\/font><\/b>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
1
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>- It was ninety one years ago, today</font></b>
2
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>Line two</font></b>
244
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>Line three</font></b>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)