const regex = /[0-9]*\n[0-9: -,->]+\n(<[^<]+>){2}([^<]+)<\/font><\/b>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]*\\n[0-9: -,->]+\\n(<[^<]+>){2}([^<]+)<\\\/font><\\\/b>', 'gm')
const str = `1
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>- It was ninety one years ago, today</font></b>
2
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>Line two</font></b>
244
00:00:07,133 --> 00:00:10,833
<b><font color='#ffd109'>Line three</font></b>`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);