const regex = /(\d{14}\s.*(?:\n*(?!^\d{14}).*)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{14}\\s.*(?:\\n*(?!^\\d{14}).*)*)', 'gm')
const str = `59105999000321 My value start
with new line number
weqweqwoe
qweqoweqioeq
qweiqwiequiweqe
oqweiqowpeqiweqpwoe
12105999000343 AAAAAasasas asdasdasd
32105999000323 asdasxasxasx asdasd
weqpowepoqwiq
qwpeqẃepoqwepqy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}