import re
regex = re.compile(r"(\d{14}\s.*(?:\n*(?!^\d{14}).*)*)", flags=re.MULTILINE)
test_str = ("59105999000321 My value start\n"
"with new line number\n"
"weqweqwoe\n"
"qweqoweqioeq\n"
"qweiqwiequiweqe\n"
"oqweiqowpeqiweqpwoe\n\n\n\n"
"12105999000343 AAAAAasasas asdasdasd\n"
"32105999000323 asdasxasxasx asdasd\n\n"
"weqpowepoqwiq\n\n"
"qwpeqẃepoqwepqy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")