$re = '/(\d{14}\s.*(?:\n*(?!^\d{14}).*)*)/m';
$str = '59105999000321 My value start
with new line number
weqweqwoe
qweqoweqioeq
qweiqwiequiweqe
oqweiqowpeqiweqpwoe
12105999000343 AAAAAasasas asdasdasd
32105999000323 asdasxasxasx asdasd
weqpowepoqwiq
qwpeqẃepoqwepqy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);