re = /(\d{14}\s.*(?:\n*(?!^\d{14}).*)*)/m
str = '59105999000321 My value start
with new line number
weqweqwoe
qweqoweqioeq
qweiqwiequiweqe
oqweiqowpeqiweqpwoe
12105999000343 AAAAAasasas asdasdasd
32105999000323 asdasxasxasx asdasd
weqpowepoqwiq
qwpeqẃepoqwepqy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end