# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([abc])([de])\2\1/Val of 1st capture group: "\1"; Val of 2nd capture group: "\2"/gm;t' <<< "adda
adbe
beeb
cdda
cddc"