$re = '/([abc])([de])\2\1/m';
$str = 'adda
adbe
beeb
cdda
cddc';
$subst = "Val of 1st capture group: \"\1\"; Val of 2nd capture group: \"\2\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;