use strict;
my $str = 'adda
adbe
beeb
cdda
cddc';
my $regex = qr/([abc])([de])\2\1/mp;
my $subst = 'Val of 1st capture group: "\\1"; Val of 2nd capture group: "\\2"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";