import Foundation
let pattern = #"([abc])([de])\2\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
adda
adbe
beeb
cdda
cddc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Val of 1st capture group: "\1"; Val of 2nd capture group: "\2""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)