re = /([abc])([de])\2\1/m
str = 'adda
adbe
beeb
cdda
cddc'
subst = 'Val of 1st capture group: "\\1"; Val of 2nd capture group: "\\2"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result