using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([abc])([de])\2\1";
string substitution = @"Val of 1st capture group: ""\1""; Val of 2nd capture group: ""\2""";
string input = @"adda
adbe
beeb
cdda
cddc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}