import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([abc])([de])\\2\\1";
final String string = "adda\n"
+ "adbe\n"
+ "beeb\n"
+ "cdda\n"
+ "cddc";
final String subst = "Val of 1st capture group: \"\\1\"; Val of 2nd capture group: \"\\2\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}