using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"type = (?<type>\S*)|count = (?<count>\d+)|destinations = (?<destinations>\S*)";
string input = @"string1 = """"
Name: default
type = Route
status = 0
count = 5
enabled = False
start_time = 18:00:00
end_time = 00:00:00
destinations = default
started = False
""""
string2 = """"
Name: default
type = Route
status = 0
enabled = False
start_time = 18:00:00
end_time = 00:00:00
destinations = default
started = False
""""
type, count and destinations";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}