package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)type = (?<type>\S*)|count = (?<count>\d+)|destinations = (?<destinations>\S*)`)
var str = `string1 = """
Name: default
type = Route
status = 0
count = 5
enabled = False
start_time = 18:00:00
end_time = 00:00:00
destinations = default
started = False
"""
string2 = """
Name: default
type = Route
status = 0
enabled = False
start_time = 18:00:00
end_time = 00:00:00
destinations = default
started = False
"""
type, count and destinations`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}