const regex = /type = (?<type>\S*)|count = (?<count>\d+)|destinations = (?<destinations>\S*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('type = (?<type>\\S*)|count = (?<count>\\d+)|destinations = (?<destinations>\\S*)', 'gm')
const str = `string1 = """
Name: default
type = Route
status = 0
count = 5
enabled = False
start_time = 18:00:00
end_time = 00:00:00
destinations = default
started = False
"""
string2 = """
Name: default
type = Route
status = 0
enabled = False
start_time = 18:00:00
end_time = 00:00:00
destinations = default
started = False
"""
type, count and destinations`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}