# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"type = (?<type>\S*)|count = (?<count>\d+)|destinations = (?<destinations>\S*)"
test_str = ("string1 = \"\"\"\n"
"Name: default\n"
"type = Route\n"
"status = 0\n"
"count = 5\n"
"enabled = False\n"
"start_time = 18:00:00\n"
"end_time = 00:00:00\n"
"destinations = default\n"
"started = False\n"
"\"\"\"\n\n"
"string2 = \"\"\"\n"
"Name: default\n"
"type = Route\n"
"status = 0\n"
"enabled = False\n"
"start_time = 18:00:00\n"
"end_time = 00:00:00\n"
"destinations = default\n"
"started = False\n"
"\"\"\"\n\n"
"type, count and destinations")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.