re = /type = (?<type>\S*)|count = (?<count>\d+)|destinations = (?<destinations>\S*)/m
str = 'string1 = """
Name: default
type = Route
status = 0
count = 5
enabled = False
start_time = 18:00:00
end_time = 00:00:00
destinations = default
started = False
"""
string2 = """
Name: default
type = Route
status = 0
enabled = False
start_time = 18:00:00
end_time = 00:00:00
destinations = default
started = False
"""
type, count and destinations'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end