import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "type = (?<type>\\S*)|count = (?<count>\\d+)|destinations = (?<destinations>\\S*)";
final String string = "string1 = \"\"\"\n"
+ "Name: default\n"
+ "type = Route\n"
+ "status = 0\n"
+ "count = 5\n"
+ "enabled = False\n"
+ "start_time = 18:00:00\n"
+ "end_time = 00:00:00\n"
+ "destinations = default\n"
+ "started = False\n"
+ "\"\"\"\n\n"
+ "string2 = \"\"\"\n"
+ "Name: default\n"
+ "type = Route\n"
+ "status = 0\n"
+ "enabled = False\n"
+ "start_time = 18:00:00\n"
+ "end_time = 00:00:00\n"
+ "destinations = default\n"
+ "started = False\n"
+ "\"\"\"\n\n"
+ "type, count and destinations";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}