#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((https?):\/\/)?(www.)?[a-z0-9]+\.[a-z]+(\.[a-zA-Z0-9#]+\/?)?[\/]?+[a-zA-Z0-9]*$"
Local $sString = "http://www.goo.com/" & @CRLF & _
"https://www.goo.com/" & @CRLF & _
"www.goo.com.dsdsas" & @CRLF & _
"http://szgmc.aiwa.ai" & @CRLF & _
"www.asd.aiwa.ai/IKDS23asdasd" & @CRLF & _
"szsacgmc.aiwa" & @CRLF & _
"szgsdmc.aiwa.ai" & @CRLF & _
"szgcsamc.aiwa.ai/" & @CRLF & _
".szgacascmc.aiwa.ai"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")