$re = '/^((https?):\/\/)?(www.)?[a-z0-9]+\.[a-z]+(\.[a-zA-Z0-9#]+\/?)?[\/]?+[a-zA-Z0-9]*$/m';
$str = 'http://www.goo.com/
https://www.goo.com/
www.goo.com.dsdsas
http://szgmc.aiwa.ai
www.asd.aiwa.ai/IKDS23asdasd
szsacgmc.aiwa
szgsdmc.aiwa.ai
szgcsamc.aiwa.ai/
.szgacascmc.aiwa.ai';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);