const regex = /^((https?):\/\/)?(www.)?[a-z0-9]+\.[a-z]+(\.[a-zA-Z0-9#]+\/?)?[\/]?+[a-zA-Z0-9]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((https?):\\\/\\\/)?(www.)?[a-z0-9]+\\.[a-z]+(\\.[a-zA-Z0-9#]+\\\/?)?[\\\/]?+[a-zA-Z0-9]*$', 'gm')
const str = `http://www.goo.com/
https://www.goo.com/
www.goo.com.dsdsas
http://szgmc.aiwa.ai
www.asd.aiwa.ai/IKDS23asdasd
szsacgmc.aiwa
szgsdmc.aiwa.ai
szgcsamc.aiwa.ai/
.szgacascmc.aiwa.ai`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}