import re
regex = re.compile(r"^((https?):\/\/)?(www.)?[a-z0-9]+\.[a-z]+(\.[a-zA-Z0-9#]+\/?)?[\/]?+[a-zA-Z0-9]*$", flags=re.MULTILINE)
test_str = ("http://www.goo.com/\n"
"https://www.goo.com/\n"
"www.goo.com.dsdsas\n"
"http://szgmc.aiwa.ai\n"
"www.asd.aiwa.ai/IKDS23asdasd\n"
"szsacgmc.aiwa\n"
"szgsdmc.aiwa.ai\n"
"szgcsamc.aiwa.ai/\n"
".szgacascmc.aiwa.ai")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")