// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((https?):\/\/)?(www.)?[a-z0-9]+\.[a-z]+(\.[a-zA-Z0-9#]+\/?)?[\/]?+[a-zA-Z0-9]*$").unwrap();
let string = "http://www.goo.com/
https://www.goo.com/
www.goo.com.dsdsas
http://szgmc.aiwa.ai
www.asd.aiwa.ai/IKDS23asdasd
szsacgmc.aiwa
szgsdmc.aiwa.ai
szgcsamc.aiwa.ai/
.szgacascmc.aiwa.ai";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}