#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\s+On.+at.+wrote:[\w\W]+"
Local $sString = "Thank you" & @CRLF & _
"That’s what I was looking for" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"On Oct 3, 2024, at 11:48 AM, test <test@test.com> wrote:" & @CRLF & _
"" & @CRLF & _
"Good afternoon," & @CRLF & _
"Thank you for your patience."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")