const regex = /\s+On.+at.+wrote:[\w\W]+/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+On.+at.+wrote:[\\w\\W]+', 'i')
const str = `Thank you
That’s what I was looking for
On Oct 3, 2024, at 11:48 AM, test <test@test.com> wrote:
Good afternoon,
Thank you for your patience.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}