import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+On.+at.+wrote:[\\w\\W]+";
final String string = "Thank you\n"
+ "That’s what I was looking for\n\n\n\n\n\n"
+ "On Oct 3, 2024, at 11:48 AM, test <test@test.com> wrote:\n\n"
+ "Good afternoon,\n"
+ "Thank you for your patience.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}