use strict;
my $str = 'Thank you
That’s what I was looking for
On Oct 3, 2024, at 11:48 AM, test <test@test.com> wrote:
Good afternoon,
Thank you for your patience.';
my $regex = qr/\s+On.+at.+wrote:[\w\W]+/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}