// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\s+On.+at.+wrote:[\w\W]+").unwrap();
let string = "Thank you
That’s what I was looking for
On Oct 3, 2024, at 11:48 AM, test <test@test.com> wrote:
Good afternoon,
Thank you for your patience.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}