$re = '/\s+On.+at.+wrote:[\w\W]+/i';
$str = 'Thank you
That’s what I was looking for
On Oct 3, 2024, at 11:48 AM, test <test@test.com> wrote:
Good afternoon,
Thank you for your patience.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);