re = /\s+On.+at.+wrote:[\w\W]+/i
str = 'Thank you
That’s what I was looking for
On Oct 3, 2024, at 11:48 AM, test <test@test.com> wrote:
Good afternoon,
Thank you for your patience.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end