#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^server(\d{1,3})(?:(-[a-zA-Z]+)(\d{1,2}))?\.mydomain\.com"
Local $sString = "server255.mydomain.com // passes, expected" & @CRLF & _
"server255-Site69.mydomain.com // passes, expected" & @CRLF & _
"server25569.mydomain.com // passes, but shouldn't" & @CRLF & _
"server255699.mydomain.com // fails, expected" & @CRLF & _
"server25569-Site.mydomain.com // fails, expected"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")