package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^server(\d{1,3})(?:(-[a-zA-Z]+)(\d{1,2}))?\.mydomain\.com`)
var str = `server255.mydomain.com // passes, expected
server255-Site69.mydomain.com // passes, expected
server25569.mydomain.com // passes, but shouldn't
server255699.mydomain.com // fails, expected
server25569-Site.mydomain.com // fails, expected`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}