// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^server(\d{1,3})(?:(-[a-zA-Z]+)(\d{1,2}))?\.mydomain\.com").unwrap();
let string = "server255.mydomain.com // passes, expected
server255-Site69.mydomain.com // passes, expected
server25569.mydomain.com // passes, but shouldn't
server255699.mydomain.com // fails, expected
server25569-Site.mydomain.com // fails, expected";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}