import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^server(\\d{1,3})(?:(-[a-zA-Z]+)(\\d{1,2}))?\\.mydomain\\.com";
final String string = "server255.mydomain.com // passes, expected\n"
+ "server255-Site69.mydomain.com // passes, expected\n"
+ "server25569.mydomain.com // passes, but shouldn't\n"
+ "server255699.mydomain.com // fails, expected\n"
+ "server25569-Site.mydomain.com // fails, expected";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}