const regex = /^server(\d{1,3})(?:(-[a-zA-Z]+)(\d{1,2}))?\.mydomain\.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^server(\\d{1,3})(?:(-[a-zA-Z]+)(\\d{1,2}))?\\.mydomain\\.com', 'gm')
const str = `server255.mydomain.com // passes, expected
server255-Site69.mydomain.com // passes, expected
server25569.mydomain.com // passes, but shouldn't
server255699.mydomain.com // fails, expected
server25569-Site.mydomain.com // fails, expected`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}