re = /^server(\d{1,3})(?:(-[a-zA-Z]+)(\d{1,2}))?\.mydomain\.com/m
str = 'server255.mydomain.com // passes, expected
server255-Site69.mydomain.com // passes, expected
server25569.mydomain.com // passes, but shouldn\'t
server255699.mydomain.com // fails, expected
server25569-Site.mydomain.com // fails, expected'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end