using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^server(\d{1,3})(?:(-[a-zA-Z]+)(\d{1,2}))?\.mydomain\.com";
string input = @"server255.mydomain.com // passes, expected
server255-Site69.mydomain.com // passes, expected
server25569.mydomain.com // passes, but shouldn't
server255699.mydomain.com // fails, expected
server25569-Site.mydomain.com // fails, expected";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}