# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b)-\n(\b)//gmu;t' <<< "Test test test te-
st test test.
Zażółć gęślą jaźń, zażółć gęś-
lą jaźń.
— Pchnąć w tę łódź je-
ża i óśm skrzyń fig! — A po co, a dla kogo!
— Wszyscy gl*niarze to s*kinsyny!
"