import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(\b)-\n(\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Test test test te-
st test test.
Zażółć gęślą jaźń, zażółć gęś-
lą jaźń.
— Pchnąć w tę łódź je-
ża i óśm skrzyń fig! — A po co, a dla kogo!
— Wszyscy gl*niarze to s*kinsyny!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)