use strict;
my $str = 'Test test test te-
st test test.
Zażółć gęślą jaźń, zażółć gęś-
lą jaźń.
— Pchnąć w tę łódź je-
ża i óśm skrzyń fig! — A po co, a dla kogo!
— Wszyscy gl*niarze to s*kinsyny!
';
my $regex = qr/(\b)-\n(\b)/mup;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";